3rd party incident on FTN Finland Mobillivermnne

Resolved

This incident has been resolved and FTN Mobiilivarmenne authentication works as normal.
Start : 18/08/2026 09:00 CEST
End: 19/08/2026 14:40 CEST
Posted Aug 19, 2026 - 14:59 CEST

Identified

The issue is been identificed and fix is being implemented.
We are sorry for inconvenience caused, We will update you once the issue is fixed.
Posted Aug 18, 2026 - 15:07 CEST

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland Mobillivermnne

DESCRIPTION:
FTN Finland Mobillivermnne services is experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Aug 18, 2026 - 11:07 CEST
This incident affected: IDP’s 3rd Party Dependencies (FTN Mobiilivarmenne).