3rd party incident on FTN Telia

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 08:00 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 07:23 CEST

Identified

DESCRIPTION:
FTN Telia is reporting issues.

INGroupe reference INC0823484

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Sep 17, 2025 - 06:00 CEST
This incident affected: IDP’s 3rd Party Dependencies (FTN Telia).