3rd party planned maintenance on Finnish Trust Network (FTN) service

Completed

The scheduled maintenance has been completed.
Posted Oct 26, 2025 - 15:00 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 03:00 CET

Scheduled

Samlink will perform maintenance work on October 26, 2025. During this period, there will be interruptions in the authentication methods of the banks listed below in the Telia Tunnistus and Telia Sign services.

Affected banks:
- Aktia Bank
- Bonum Bank
- Handelsbanken (Finland)
- Oma Savings Bank
- POP Banks
- Savings Banks
- Central Bank of Savings Banks Finland
Posted Oct 23, 2025 - 10:42 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Aktia, FTN Oma SP, FTN Pop Pankki, FTN S-Pankki, FTN Telia).