3rd party maintenance on FTN Finland

Completed

The scheduled maintenance has been completed.
Posted Apr 24, 2026 - 05:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2026 - 23:10 CEST

Scheduled

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland

DESCRIPTION:
Our eID connection towards this 3rd party service is running but might experience issues as a result of their maintenance.

CONSEQUENCE:
During the service window, FTN Finland services may be unavailable.

NOTE: Questions can be directed to support.esecurity@nets.eu
Posted Apr 23, 2026 - 23:06 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN OP).