3rd party planned maintenance on Finnish Trust Network (FTN) service

Completed

The scheduled maintenance has been completed.
Posted Aug 24, 2025 - 11:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2025 - 04:01 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 19, 2025 - 15:36 CEST

Scheduled

Samlink will perform maintenance work on Sunday 24 Aug. 2025 from 05:00 a.m. and 12:00 a.m. (Finnish time), during which the identification services of the banks listed below will not be available

Affected banks:
- Aktia Bank
- Bonum Bank
- Handelsbanken (Finland)
- Oma Savings Bank
- POP Banks
- Savings Banks
- Central Bank of Savings Banks Finland
Posted Aug 19, 2025 - 12:43 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Aktia, FTN Oma SP, FTN Pop Pankki, FTN S-Pankki).