3rd party incident on ID Rights

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 13:47 CEST

Investigating

Unfortunately, Experian experienced an error in their database yesterday evening between 17:53 and 19:56, which caused temporary downtime in systems using Experian systems.

The systems and solutions are up and running now.
Posted Sep 10, 2025 - 13:45 CEST
This incident affected: ID-Rights (Experian).