Emergency maintenance on SK ID Solutions

Completed

The scheduled maintenance has been completed.
Posted Sep 11, 2025 - 02:30 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2025 - 22:30 CEST

Scheduled

Please be advised that SKID will be performing emergency maintenance on its Solutions services from 10.09 22:30 until 11.09 02:30 CET.
Maintenance work might cause short disruptions in SK services

Regular redundancy testing of all SK services will be performed on 18.09.2025 from 22:00 until 19.09.2025 01:00 CET.
The test will cause momentary disruptions in SK services after 22:00.
Posted Sep 09, 2025 - 10:00 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (Smart-ID, Mobile-ID).