3rd party maintenance on FTN Finland

Completed

The scheduled maintenance has been completed.
Posted Jun 01, 2026 - 07:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2026 - 15:00 CEST

Scheduled

THIS NOTIFICATION APPLIES TO:
Customers using FTN POP Bank for Identification and/or Signing.

DESCRIPTION:
FTN POP Bank is changing their core banking provider from Samlink to Crosskey. Transition will be carried out during indicated maintenance window.

CONSEQUENCE:
During the service window, FTN POP Bank services will be unavailable. Normal operation will resume from Monday morning.

NOTE: Questions can be directed to support.esecurity@nets.eu
Posted May 19, 2026 - 13:29 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Pop Pankki).