Potential Incident detected in the E-Ident and the Finnish Trust Network (FTN)
Resolved
The E-Ident and the Finnish Trust Network (FTN) services are back in normal operation.
Posted Oct 08, 2024 - 17:13 CEST
Identified
The E-Ident and the Finnish Trust Network (FTN) services are experiencing an incident. Issue is located to FTN Nordea.
Nordea has identified the issue on their end and are working on a fix. We anticipate normal operation within the day
Posted Oct 08, 2024 - 12:54 CEST
Investigating
Nets have discovered a potential issue in The E-Ident and the Finnish Trust Network (FTN). Nets is currently investigating the issue

End users may experience problems when trying to log in.
Posted Oct 08, 2024 - 12:32 CEST
This incident affected: E-Ident (E-Ident and FTN).