Upcoming ID Verifier iOS Production Release – September 12, 2025

Completed

The scheduled maintenance has been completed.
Posted Sep 12, 2025 - 13:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2025 - 11:00 CEST

Scheduled

We’re pleased to announce the production release of the ID Verifier app for iOS on September 12, 2025.

This update is required to ensure full compatibility with iOS 26. Once iPhones upgrade to iOS 26, the app must also be updated to maintain seamless access. We recommend all users install the latest version promptly to avoid service disruption.

Key updates include:
• Improved biometric performance
• Compatibility with iOS 26
• Enhanced error logging
• Fix for remote biodata uploads

Thank you for your continued support and collaboration.

NOTE:
Questions can be directed to support.esecurity@nets.eu.
Link to developer pages for ID Verifier: https://doc.ingroupe.com/developer/id-verifier
Posted Sep 11, 2025 - 15:07 CEST
This scheduled maintenance affected: E-Ident (ID Verifier).