3rd party incident on OP Bank with FTN Finland

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 14:13 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2026 - 12:00 CET

Identified

The issue is with the 3rd party service. 3rd party service (OP Bank) is working on a solution.
Posted Jan 15, 2026 - 11:18 CET

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using OP Bank with FTN Finland.

DESCRIPTION:
All FTN Finland services using OP Bank are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Jan 15, 2026 - 11:09 CET
This incident affected: IDP’s 3rd Party Dependencies (FTN OP).