Experian Maintenance - Extraordinary Service window

Completed

The scheduled maintenance has been completed.
Posted Dec 09, 2025 - 04:00 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 00:00 CET

Scheduled

We would like to inform you about an extraordinary service window scheduled for Tuesday, December 9, starting at 00:00 (midnight).

Please note that this may cause temporary disruptions to Experian’s services and products during this period.
Posted Dec 05, 2025 - 08:19 CET
This scheduled maintenance affected: ID-Rights (Experian).