3rd party planned maintenance on Omasp, Finnish Trust Network (FTN) service

Completed

The scheduled maintenance has been completed.
Posted Aug 24, 2025 - 11:01 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2025 - 04:00 CEST

Scheduled

OMASP's online services is announcing maintenance Sunday, August 24, 2025
from 4:00 a.m. to 11:00 p.m (CEST).

During the outage, the bank identification service will not be possible
Posted Aug 20, 2025 - 15:08 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Oma SP, FTN Telia).