3rd party planned maintenance on OP Bank

Completed

The scheduled maintenance has been completed.
Posted Oct 26, 2025 - 02:00 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2025 - 00:00 CEST

Scheduled

There will be interruptions in OP Banks online and mobile services due to information system maintenance. During the service break there will be interruptions when login to OP services using Mobile key, but you can use your key code list.
Posted Oct 24, 2025 - 14:52 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN OP).