Nets is experiencing operational disturbances with the E-Ident and the Finnish Trust Network (FTN) services

Resolved

INC0733113 has been resolved. Caused by a DDOS attack against an external implementor.
Posted Mar 19, 2025 - 17:47 CET

Update

We are continuing to monitor for any further issues.
Posted Mar 19, 2025 - 17:43 CET

Monitoring

The E-Ident and the Finnish Trust Network (FTN) services are back in normal operation.

Monitoring the status
Posted Mar 19, 2025 - 16:25 CET

Investigating

INFORMATION
A possible incident for the E-Ident and the Finnish Trust Network (FTN) services has been detected and is under investigation.

CONSEQUENCES
The customer impacts are currently not known.
Posted Mar 19, 2025 - 14:19 CET
This incident affected: E-Ident (E-Ident).