Trust Archive-DocArc customer- deploying a service update

Completed

The scheduled maintenance has been completed.
Posted May 12, 2026 - 22:55 CEST

Scheduled

THIS NOTIFICATION APPLIES TO:
Customers using Trust Archive - DocArc

DESCRIPTION:
Archive service (DocArc) will have a service window < 12.05.2026 between 22:00-23:00 >.

CONSEQUENCE:
To address a known issue affecting Trust Archive-DocArc customer, Trust Archive will be deploying a service update (CHG0409016). This change is being implemented to restore expected functionality. There will be no service downtime during the update.

NOTE: Questions can be directed to support.esecurity@nets.eu
Posted May 11, 2026 - 11:16 CEST
This scheduled maintenance affected: Archive (DocArc).