3rd party planned maintenance on Omasp, Finnish Trust Network (FTN) service

Completed

The scheduled maintenance has been completed.
Posted Mar 23, 2025 - 13:15 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 23, 2025 - 04:00 CET

Scheduled

DESCRIPTION:
The Finnish bank Oma Säästöpankki have announced a service window for their identification services.

CONSEQUENCE:
During the service window, identifications with the banks through the FTN service will be unavailable.

NOTE:
Questions can be directed to support.esecurity@nets.eu
Posted Mar 19, 2025 - 13:56 CET
This scheduled maintenance affected: E-Ident (E-Ident).