FTN- Termination of support for Handelsbanken Finland

Completed

The scheduled maintenance has been completed.
Posted Aug 20, 2025 - 12:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 10:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 07, 2025 - 12:09 CEST

Scheduled

DESCRIPTION:
This is with reference to the notification received from Svenska Handelsbanken AB (publ), stating Handelsbanken was removed from the register of strong identification service providers 1.4.2025

CONSEQUENCE:
1. In Groupe has removed forcebank support for Handelsbanken. This implies customers selecting Handlesbank through forcebank parameter should stop sending it.
2. On Bank selection (Select ID Provider page inside BankID FI) screen, Handelsbanken will be removed from the list.


NOTE:
Questions can be directed to support.esecurity@nets.eu.
Link to developer pages for E-Ident: BankID (NO)
Posted Jul 07, 2025 - 09:27 CEST