Maintenance of SK services

Completed

The scheduled maintenance has been completed.
Posted Jan 22, 2026 - 01:30 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2026 - 22:00 CET

Scheduled

We would like to inform you that SK ID Solutions will carry out regular IT infrastructure maintenance works between 21.01.2026 at 22:00 and 22.01.2026 at 01:30.
On 22.01 from 23:00 to 01:30 there may be short-term interruptions in the operation of Eesti Mobile-ID.

Please note that additional steps may need to be taken in connection with the DigiDoc4j news. More information:
https://www.skidsolutions.eu/news/services-using-digidoc4j-action-required/

Maintenance work ensures better quality, confidentiality, integrity and security of our services. SK ID will try to keep the interruption time as short as possible.
Posted Jan 16, 2026 - 07:32 CET
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (Smart-ID, Mobile-ID).