Maintenance of SKID services - Mobile ID

Completed

The scheduled maintenance has been completed.
Posted Oct 24, 2025 - 00:30 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 22:00 CEST

Scheduled

Please be advised that SKID will be performing a scheduled maintenance on SK ID Solutions' IT infrastructure on 23.10.2025 from 22:00 until 24.10.2025 12:30 CET.
Estonian Mobile-ID service may experience brief interruptions from 22:00 until 12:30 CET. Maintenance works will provide more confidentiality, integrity and availability to assure the quality of SKID services.
Posted Oct 15, 2025 - 16:10 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (Mobile-ID).