3rd party incident on FTN Finland

Resolved

Services are working fine. Downtime due to 3rd party incident: 7 AM to 9 AM CET (Mar 25)
Posted Mar 25, 2026 - 10:42 CET

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland - Oma Säästöpankki, Säästöpankki and POP Pankki.

DESCRIPTION:
All FTN Finland services using Oma Säästöpankki, Säästöpankki and POP Pankki are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Mar 25, 2026 - 10:37 CET
This incident affected: IDP’s 3rd Party Dependencies (FTN Oma SP, FTN Pop Pankki).