3rd party incident on ID-Rights Experian

Resolved

3rd party issue - resolved.
Posted Apr 27, 2026 - 10:38 CEST

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using ID-Rights Experian.

DESCRIPTION:
All ID-Rights Experian services are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Apr 27, 2026 - 10:30 CEST
This incident affected: ID-Rights (Experian).