3rd party maintenance on Nordea electronic identification

Completed

The scheduled maintenance has been completed.
Posted Apr 26, 2026 - 11:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2026 - 01:00 CEST

Scheduled

Nordea will perform maintenance on its services on 26 April' 2026. During this time, Nordea banks electronic identification will not be available in the Telia Identification Service.
Posted Apr 21, 2026 - 10:33 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Nordea).