3rd party maintenance at Samlink

Completed

The scheduled maintenance has been completed.
Posted Mar 22, 2026 - 14:30 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2026 - 05:00 CET

Scheduled

Samlink will carry out maintenance work on Sunday, 22 March 2026 from 05:00-14:30. During the maintenance, the electronic identification of the banks listed below will experience disruptions in the Telia Identification Service.

- Aktia Pankki
- Bonum Pankki
- Handelsbanken
- Oma Säästöpankki
- POP Pankit
- Säästöpankit
Posted Mar 18, 2026 - 11:12 CET
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Aktia, FTN Oma SP, FTN OP, FTN Pop Pankki, FTN S-Pankki).