INC0962753 : 3rd party incident on FTN Finland Savingsbank [Säästöpankki]

Resolved

This is false alarm.
Got few callbacks for older failed transactions failed during maintenance window, are failed to fetch the idtoken.
So services are working as normal. just older failed transactions has created this incident.
Posted Aug 24, 2026 - 09:21 CEST

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland Savingsbank [Säästöpankki]

DESCRIPTION:
FTN Finland Savingsbank [Säästöpankki] services are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Aug 24, 2026 - 08:40 CEST
This incident affected: IDP’s 3rd Party Dependencies (FTN Säästöpankki Savingsbank).