3rd party maintenance at Aktia banks

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 10, 2025 - 10:30 CET

Scheduled

Maintenance work will be carried out on Aktia banks online services on 10 December 2025. During this time, there may be disruptions in Aktia authentication in the Telia Identification Service.
Posted Dec 05, 2025 - 12:10 CET
This scheduled maintenance affects: IDP’s 3rd Party Dependencies (FTN Aktia).