3rd party maintenance at Aktia banks

Completed

The scheduled maintenance has been completed.
Posted Dec 03, 2025 - 08:30 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2025 - 05:30 CET

Scheduled

Maintenance work will be carried out on Aktia banks online services on 3 December. During this time, there may be disruptions in Aktia authentication in the Telia Identification Service.
Posted Dec 02, 2025 - 14:14 CET
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN Aktia).