Third party Maintenance, SKID services - Mobile ID

Completed

The scheduled maintenance has been completed.
Posted Nov 14, 2025 - 01:30 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 22:00 CET

Scheduled

We would like to inform you that our third-party partner SK ID Solutions AS will carry out regular IT infrastructure maintenance works between 13.11.2025 at 22:00 CET and 14.11.2025 at 01:30 CET.
On 13.11 from 22:00 to 22:59, there may be short-term interruptions in the operation of Lithuanian Mobile-ID, there may be short-term interruptions in the Estonian Mobile-ID service on 14.11 between 23:00 and 01:30.
Posted Nov 06, 2025 - 09:21 CET
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (Mobile-ID).