Additional Claims in BankID NO ID Tokens

Completed

The scheduled maintenance has been completed.
Posted Jan 07, 2026 - 14:00 CET

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 07, 2026 - 12:00 CET

Scheduled

We would like to inform you that we are adding additional claims to the ID tokens generated for BankID NO identifications. This enhancement is designed to provide more comprehensive information and to improve integration with your systems. Please find details on additional claims below:

acr: Appended new values to the existing acr claim using comma separation. Example- urn:eident:cert:eidas:high;urn:bankid:bid;LOA=4
azp: Added as a new claim under the openid scope.
originator: Represented using the existing claim issuing_authority, available under the profile scope.
updated_at: Represented using the existing claim issue_date, available under the profile scope.

Sample ID Token After Update:
{
"sub" : "no_bankid:9578-6000-4-237729",
"birthdate" : "02.12.1921",
"amr" : [ "no_bankid" ],
"iss" : "https://www-ident-test.nets.no/oidc",
"pid" : "9578-6000-4-237729",
"no_bid_pid" : "9578-6000-4-237729",
"given_name" : "Haider",
"nonce" : "nonce22/12/2025",
"no_ssn" : "02122134760",
"ssn" : "02122134760",
"aud" : "MER2",
"acr" : "urn:eident:cert:eidas:high;urn:bankid:bid;LOA=4",
"issue_date" : "1758613431",
"ssn_issuing_country" : "NO",
"azp" : "sis_nets-bankid-current",
"issuing_authority" : "CN=BankID - TestBank1 - Bank CA 3,OU=123456789,O=TestBank1 AS,C=NO;OrginatorId=9980;OriginatorName=BINAS;OriginatorId=9980",
"name" : "Test, Haider",
"exp" : 1766401188,
"iat" : 1766400288,
"family_name" : "Test",
"jti" : "26e28a1b42184ca48e9bbb4d5a944695"
}

These changes ensure consistency while providing additional information for improved integration and compliance.

NOTE:
Questions can be directed to support.esecurity@nets.eu.
Link to developer pages for E-Ident: BankID (NO)
Posted Dec 22, 2025 - 13:58 CET
This scheduled maintenance affected: E-Ident (E-Ident).