3rd party maintenance on FTN POP Bank

Completed

The scheduled maintenance has been completed.
Posted May 20, 2026 - 03:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 01:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 12, 2026 - 14:36 CEST

Scheduled

THIS NOTIFICATION APPLIES TO:
Customers using FTN POP Bank

DESCRIPTION:
FTN POP Bank is changing their core banking provider from Samlink to Crosskey. To verify that the switch over works in production, we need to verify the Crosskey's test setup. Verification will involve some service disruption

CONSEQUENCE:
During the service window, FTN POP Bank services may be unavailable. This includes Signing done with POP Bank

NOTE: Questions can be directed to support.esecurity@nets.eu
Posted May 12, 2026 - 14:32 CEST
This scheduled maintenance affected: E-Signing (E-Signing) and IDP’s 3rd Party Dependencies (FTN Pop Pankki).