3rd party planned maintenance on OP Palveluhallintakeskus, Finnish Trust Network (FTN) service

Completed

The scheduled maintenance has been completed.
Posted Aug 31, 2025 - 06:00 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 30, 2025 - 22:00 CEST

Scheduled

OP Palveluhallintakeskus will be performing maintenance work on August 30th at 22:00 to August 31st 6:00 AM (CEST).

There will be interruptions in their online and mobile services due to information system maintenance. During the interruptions, you can't log into OP’s services using Mobile key, but you can use your key code list.
Posted Aug 29, 2025 - 11:47 CEST
This scheduled maintenance affected: IDP’s 3rd Party Dependencies (FTN OP).