Nets is experiencing operational disturbances within Signing and Identification services
Monitoring
The Signing and Identification services are back in normal operation.

We keep monitoring the situation
Posted Oct 15, 2024 - 11:08 CEST
Update
We are continuing to investigate this issue.
Posted Oct 15, 2024 - 10:34 CEST
Update
Increased response time seen for all SIS services and some failed transactions

Still trying to identifying the root cause.

INC0676944
Posted Oct 15, 2024 - 10:27 CEST
Investigating
INFORMATION
A possible incident for the E-Ident and the Finnish Trust Network (FTN) services has been detected and is under investigation.

CONSEQUENCES
The customer impacts are currently not known.
Posted Oct 15, 2024 - 10:03 CEST
This incident affects: E-Signing (E-Signing), E-Ident (E-Ident and FTN, Nets IDV), and ID-rights.