ID-Rights maintenance
Completed
The scheduled maintenance has been completed.
Posted Nov 09, 2024 - 10:45 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2024 - 10:03 CET
Scheduled
The Norwegian Tax Administration (Skatteetaten) reports that they will conduct an annual infrastructure test. This will result in downtime for the National Population Register (FREG) during this period, and ID-Rights service depending on FREG will also be unavailable during this time.
Posted Nov 06, 2024 - 14:31 CET
This scheduled maintenance affected: ID-rights.