New Pre-Production Release Available: ID Verifier App for iOS.

Completed

The scheduled maintenance has been completed.
Posted Sep 09, 2025 - 16:04 CEST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 15:04 CEST

Scheduled

We are pleased to announce the new Pre-Production release of the ID Verifier app for iOS, featuring critical updates to ensure full compatibility with iOS 26. This release includes several key enhancements and addresses high-priority issues identified during recent testing:

• Improved biometric performance
• Resolved compatibility issues with iOS 26 Beta
• Enhanced error logging capabilities
• Corrected an issue affecting remote biodata uploads

The updated app is now available for testing and can be downloaded via the following link: https://apps.apple.com/us/app/test-id-verifier/id6743443393

We are targeting a Production release in September 2025, with the exact launch date to be confirmed shortly.
Thank you for your continued support and collaboration.

NOTE:
Questions can be directed to support.esecurity@nets.eu.
Link to developer pages for ID Verifier: https://doc.ingroupe.com/developer/id-verifier
Posted Sep 09, 2025 - 15:02 CEST
This scheduled maintenance affected: E-Ident (ID Verifier).