3rd party incident on ID-Rights Experian

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 09:40 CEST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 09:38 CEST

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using ID-Rights Norway.

DESCRIPTION:
ID-Rights Norway is experiencing some issue at present. Concerning team is working in resolving the issue.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Apr 20, 2026 - 10:17 CEST
This incident affected: ID-Rights (Experian).