3rd party incident on Mobile-ID

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 07:02 CET

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland.

DESCRIPTION:
Telia FTN Finland services are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Oct 30, 2025 - 06:33 CET
This incident affected: IDP’s 3rd Party Dependencies (FTN Telia).