INC0962590 : 3rd party incident on FTN Finland

Resolved

FTN service is restored and works back to normal.
Posted Aug 23, 2026 - 18:49 CEST

Update

savingsbank [Säästöpankki] and OmaSp has maintenance downtime up to 23-08-2026 17:00 CEST.
So Authenticatoin with these FTN banks may not work during this period.
Posted Aug 23, 2026 - 14:47 CEST

Update

We are continue investigating the issue.
Issue is been reported to savingsbank FTN.
If you face FTN authentication transaction failure with savingsbank [saastopankki] then please retry later.
Posted Aug 22, 2026 - 15:55 CEST

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using FTN Finland savingsbank [saastopankki]

DESCRIPTION:
FTN Finland savingsbank [saastopankki] services may experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Aug 22, 2026 - 14:29 CEST
This incident affected: IDP’s 3rd Party Dependencies (FTN Aktia, FTN Oma SP, FTN S-Pankki).