3rd party incident on FTN Finland using OP Bank

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 18:12 CET

Identified

OP Bank is working on a solution.
Posted Jan 15, 2026 - 16:11 CET

Investigating

THIS NOTIFICATION APPLIES TO:
Customers using OP Bank on FTN Finland.

DESCRIPTION:
All FTN Finland services using OP Bank are experiencing an incident.

CONSEQUENCE:
End users and customers might experience problems when trying to use the services.
Posted Jan 15, 2026 - 16:11 CET
This incident affected: IDP’s 3rd Party Dependencies (FTN OP).